配置 qt creator 3.2.2 debugger for mingw

新版本的qt creator 3.2.2 要求 GDB 7.6以上,且支持python。所以老版本的,也包括从mingw官网里下载过来如GDB 7.6的都不能用。

新版的Qt往往自带qt creator,直接安排就好,但老版本的,比如qt 4.8版本就需要自己配置。很费一翻劲。

qt 4.8要求mingw GCC 4.4.0,现在qt官网上都已经不提供。我以前从nokia ftp上下载来的mingw-gcc440_1.zip,可以用。但里面自带的gdb是6.8版本,不能被新版本的qt creator所用。如果不想用qt creator 3.x,那得倒退到2.0以前的版本吧(我测试过creator 2.5.2版是不能用的)。

然后从非官方的gdb for mingw下载支持python版的gdb。地址是http://sourceforge.net/projects/gdbmingw/files/?source=navbar。我的测试是目前最新的gdb2014-05023.zip就可以用。

将下来的gdb-python解压缩覆盖到 mingw的安装目录,会提示覆盖,覆盖即是。

此外还需要安装 python 2.7,从python官网下载即是,但最好是 2.7.5版本以上,我的是2.7.8。gdb好像不支持python 3.x。

然后在creator里手工配置Tools > Options > Build & Run 里的 Qt versions, Compilers, 和Debuggers,保存后,配置Kits。即可。

一个启示是如果我们想编译qt 4.x  for mingw版本,qt creator可以不必是基于mingw,但gdb必须是基于mingw,且是被qt creator识别的支持python版本的。

Read on mobile:qr code

Leave a Reply

Your email address will not be published. Required fields are marked *